3.3.1. Sintaxis de las funciones

El formato general de una función es el siguiente

=NOMBRE DE LA FUNCIÓN(argumento1; argumento2; …)

El signo igual (=) sirve para que Excel interprete la entrada como una fórmula y no como texto.

El Nombre de la función es una palabra clave dada por Excel a cada función. Lo escribiremos tal y como Excel lo tiene definido indistintamente en mayúsculas y minúsculas.

Los Argumentos son opcionales; las fórmulas pueden tener uno, varios o ninguno. Representan los distintos parámetros que intervienen, cantidades o referencias sobre los que va a operar la función.

El número de argumentos de una función varía entre 0 y 30, separados por el carácter de punto y coma (;), no pudiendo sobrepasar los 255 caracteres. Se recomienda no dejar espacios en blanco entre los diferentes argumentos.

Si se utiliza un rango como argumento (A1:B6), Excel lo considera un único argumento. Así, por ejemplo, la función =SUMA(A1:A6), que realizaría la suma del rango de celdas entre A1 y A6, contendría un único argumento. Si se ha dado nombre a un rango, podemos emplear también este nombre como argumento.

Excel admite como argumentos otras funciones, pudiendo construir así hasta siete niveles de anidamiento.

Ejemplos de diversos tipos de argumentos:

  • Numéricos: =PROMEDIO (34;23;10)
  • Direcciones de celdas (referencias): =SUMA(B1..B23) o =SUMA(B1:B23)
  • Texto: Debe escribirse entre comillas.
  • Condiciones:= SI(A1>5;»ÓPTIMO»;»ENTRADA NO VÁLIDA»)
  • Sin argumentos: = HOY( )
  • Nombres de celdas: =SUMA(salario)
  • Funciones: =SUMA(SENO(G5);RAIZ(ABS(PROMEDIO(A1:A20))))

Inicio Foros 3.3.1. Sintaxis de las funciones

  • Este debate tiene 2 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 1 año, 5 meses por paraninfo.
Viendo 3 entradas - de la 1 a la 3 (de un total de 3)
  • Autor
    Entradas
  • #1409 Responder
    paraninfo
    Superadministrador

    El formato general de una función es el siguiente =NOMBRE DE LA FUNCIÓN(argumento1; argumento2; …) El signo igual (=) sirve para que Excel interpret
    [See the full post at: 3.3.1. Sintaxis de las funciones]

    #2463 Responder
    roger salazar
    Invitado

    conta

    #2464 Responder
    roger salazar
    Invitado

    muy buenas yardes me interesa comprar el dominio de usted por la forma que esta estructurada, soy estudiante de peru y quiero compartir mis conocimientos.
    si te interesa contacteme a [email protected]

Viendo 3 entradas - de la 1 a la 3 (de un total de 3)
Respuesta a: 3.3.1. Sintaxis de las funciones
Tu información: